Main Menu


File Menu

New (Ctrl+N) - erases the ArtWonk Module Workspace, and any Widgets that were in the Panel. If there were changes made to the current Workspace you will first be asked if you want to Save.

 Open... (Ctrl+O) - invokes a standard Windows dialog box to open a previously created ArtWonk patch (.awp) file. You can also open patch files by double clicking on the file name in the Windows explorer or by dragging them onto the ArtWonk Workspace; and when you first load ArtWonk if a valid patch file name is given in the command line, the file will be opened at startup.

Save (Ctrl+S) - Saves the currently opened Patch file. If none have been opened, acts as Save As. If there were changes to the file, the previous version is copied to the backup folder (..\Patches\MySaved\Backup\) before it is overwritten.  Automatic backup can be turned off in the Global Options.

SaveAs... - Invokes the standard Windows File Save dialog to save the ArtWonk patch. 

Save Patch Pic -This just saves the Patch screenshot, not the patch.  Useful for when importing patch files that do not have screenshots, or for updating the patch picture only.

Archive - Sends a copy of the current patch to the archive folder, "..\Patches\MySaved\Archive\."  Copies the .awp patch file as well as the screenshot and .htm help file, if any. The first time a file is copied, it keeps the original name.  Subsequent copies will have numbers appended, as filename-01, filename-02, etc. So you can use this as a straight up archive folder or you can use it for intermediate saves of patch files as you develop them.

Delete - Moves current patch to the junk folder, "..\Patches\MySaved\Junk\".  Does not actually delete the patch, just moves it out of the way so you can do a real delete later if you like. Moves .awp patch file and associated image and .htm patch info files if any.

Quick Save (Ctrl+Q) - Saves the current patch as a Quick file for fast access file. There are 10 Quick files, named Quick0 to Quick9. These are rotated so that Quick Save will always save to the one least recently used. The menu indicates which of the Quick files is to be saved next.

Quick Load (Ctrl+L) - Loads the last patch saved by Quick Save. The menu indicates which of the Quick# files is up for loading. If you need to load a previously saved Quick File, you can use the Open Quick command to load it from the Patches/Quick directory.

Open Quick - Opens the Quick Save file history, so you can open a Quick Save file from the up to 10 previous saves.

CreateAVI... - Invokes a dialog window to create an AVI video from either a directory of frame stack images, or in real time by capturing directly from the Canvas. This will create an AVI up to the standard limit of 2 GB. (ArtWonk only.)

DecompileAVI... - Invokes a dialog to create a frame stack from an existing AVI file. (ArtWonk only.)

Load BioSeq... - Invokes an open dialog to load Bio Sequencer .bst files created by the Bio Editor. ArtWonk's BioSeq module uses these files to read and sequence DNA and amino acid data from genetic sequence files.

Load Tuning Table... - Opens a Tuning Table .pbt data file created by MicroTone and makes it the current source of tunings for the MIDI Tone modules. Does not alter the default tuning table file.

Import MIDI File... - Invokes a dialog box for importing MIDI files and converting them to a sequencer format that is compatible with the ArtWonk MIDIFile Module.

The dialog has a window on the left that shows all the tracks that are in the MIDI file, one on the right that shows the events within a track, and a column of16 channel buttons in the middle, which will show which channels are available on the selected track. Often there is only one MIDI channel per track; sometimes there is only one track with multiple channels. Whatever the combination of tracks and channels within a track, the channel buttons will become enabled for however many tracks there are, and if more than one you can choose a particular channel.

The window on the right allows you to select the actual MIDI message data to be imported. Click on Save or double click on an item in the MIDI Data (right side) window, and a file save dialog box pops up with the file already named with the original filename plus the track number and message-type (Vel (velocity), Key, Pan, etc) appended. The event data is saved in a special format that is optimized for efficient playback by the MIDI File module.

Exit - Exits ArtWonk. If there were changes made you will first be asked if you want to Save. Same as the Windows Close "X" icon in the upper right of the title bar.

Recently Opened File List - The 8 most recently opened files are listed here. Select a file name to open it.


MIDI Menu

Pops up the MIDI Options dialog, so you can set MIDI input and output devices and other MIDI related options.



MIDI Port 0-3 - These 4 tabs display the settings for each of the 4 MIDI ports that are available. Each port can have its own settings.

MIDI Out Device Driver - Drop down menu of available MIDI Out drivers available on your computer. If you are not sure what to select, select the "Microsoft MIDI Mapper" as shown on the screenshot.  This is the default that has been set for playing MIDI files on your computer and almost always works.  You could also try the "Microsoft GS Wavetable Synth" which is available in all Windows computers since XP; usually this is the one the Mapper points to, but if you are having trouble with the Mapper selection, sometimes going right to the Wavetable Synth will work.

MIDI In Device Driver - Drop down menu of available MIDI In drivers.  ArtWonk can process MIDI Input, but for the most part ArtWonk is a MIDI Out generator, and except for more advanced work where you have a specific reason to capture MIDI In messages it's best to leave this selection unselected.

All Notes Off - Almost all modern synths, soft synths and samplers respond to the MIDI ANO message (that you send with the toobar ANO button or keyboard F2), which tells the device to stop making sound. So normally this is all you need for shutting off a synth with a stuck note. Default is on, checked.

All Keys Off - Some of the older synths don't respond to the standard MIDI ANO message, so in order to turn off a stuck note the software has to send a MIDI Key Off message for each key in each of the 16 MIDI channels.  If the normal ANO doesn't turn off a stuck key, try this setting.  Default is off, unchecked.

Reset Controls - If you have a stuck note making a racket, in addition to sending an ANO it's a good idea to reset the controllers as well.  That's what this does, it adds a Reset Controllers message to the ANO.  Default is on, checked.

Active Sensing - Synths can be set up so they listen to a MIDI message called Active Sensing which basically tells the synth you are still here.  With this option checked ArtWonk sends the message.  Default is off, unchecked.

SB Banks - There are two ways to send MIDI Bank changes, one used mostly by Sound Blaster and one used by most other devices.  If Bank change isn't working, try checking (or unchecking) this option.  Default is unchecked, to use standard RPN Bank change.

Expr CC: 11 - MIDI Continuous Controller for Expression is 11, and is the default here.  However you can change it to whatever you want by typing in a different value.  This only affects the MIDIVoice, MIDIChannel and MIDITone modules.  Expression is usually a 2nd volume control and rarely needed in these modules, so with this option you can use that CC# for some other parameter.

MIDI Sync - Part of the MIDI specification is that you can synchronize MIDI devices with one as the master and any number of others as slaves. ArtWonk supports either role.  Since sync requires other synths, this setting is not remembered.  You need to set it up every time you want to run multiple MIDI devices in sync.

ProgChg -> Snapshots - Check this is you want ArtWonk to change Snapshots as if they were MIDI Programs; select the port and channel to receive the Program change messages from in the drop down menu under the checkbox.


BioEditor

The BioEditor converts data from DNA and protein sequence text files into a numerical table format (.bst). Although there are a number of controls in the BioEditor, most of them are for delimiting secondary structure features such as turns, alpha helices, and beta sheets - which can be used to trigger musical changes or events. For a simple, direct translation of the protein or DNA data, you need only to read in the file and set markers for the beginning and end of the data. For more information on how to use the BioEditor to discover the sounds of DNA, see the BioEditor Help files and the BioEditor Tutorial.


DataBin

DataBin converts text data into binary number files. DataBin reads just about any text based data file with numbers in any range. Once the source data file is read into the text window, you can pick whether to convert all numbers, or select a field and convert just the numbers in that field. The values you select are charted in the graphical display window, to give you a quick idea of the data's shape. You can save it as a binary file with the data normalized to the 0-127 MIDI range, or as the original values in either floating point or ArtWonk sequencer/array format. See the DataBin Help files for complete information.


MicroTone

MicroTone creates microtonal tunings by automatically combining MIDI Note and MIDI Pitch Bend. The program does not generate music, rather it generates a set of tables that will translate MIDI notes of an arbitrary tuning table (such as Just Intonation) into MIDI Notes and Pitch Bend values that will give the correct pitch for each scale step. See the MicroTone Help files for complete information.


Options Menu

Notes Off (F2) - Turns off stuck notes on all connected MIDI devices. You can select various All Note Off options with the MIDI Option dialog above. Duplicated in Panel Toolbar.

Graphics (F3) - Shows the Graphics Display screen if it had been hidden; hides it if it had been showing.

Bio Pitch Tables - Pops up a dialog box with 21 sliders for the pitch tables for bio sequence Amino Acid Notes.  This is the set of pitch translation tables for the 21 possible amino acid values produced by the Bio Sequencers and accessible with the AANote module.

Global Options - Customize some of the default ArtWonk global settings:|

Play Button on Taskbar Tray - Duplicates the Play button on the Windows Taskbar tray, giving the ability to "remote control" ArtWonk while it is minimized or behind other program windows.

Only Show when Minimized - Only shows the Play button in the Windows Taskbar tray when ArtWonk is minimized.

Display Output Precision - sets the floating point precision module outputs display. Actual precision is unchanged.

Mouse Wheel Sensitivity - adjust mouse wheel response sensitivity. Set to 0 to disable mouse wheel.

Module Graphics Display Rate - sets the interval in milliseconds that the module readout values are updated. The default is 200 milliseconds, 5 times a second, which is about as fast as you can make sense of them, and has minimal impact on CPU usage. This does not affect readouts in the Panel, which always display instantly when changed.

Widget Fast Frame Move Threshold - When moving a group of widgets, if the number of widgets you are moving is greater than the threshold, only the frame will show as the widgets are being moved. This increases performance at the cost of not being able to see each widget as it is being moved. The default threshold is 8, so moving 8 or fewer widgets will show each widget during the move, moving more than 8 at a time will show only the frame. Faster computers can display larger numbers of widgets during a move without bogging down, so the default threshold of 8 can be changed to any number you like from 1 to 256.

Set Default Colors - check to return the Panel and Workspace to the default colors.

Panel Back Color - click on the button to change the Panel background color.

Workspace Back Color - click on the button to change the Workspace background color.

Display Behavior on Minimize - 'Follow Art Wonk Window' connects the graphics screens (Canvas and Screens 1-4) to minimize with the main window. 'Remain Visible if ON' allows the graphics screens to remain visible when you minimize the main ArtWonk window.

Panel Grid & Workspace Grid -controls the screen area snap grid and the displayed grid which may be different from the snap grid. The default snap is 4x4, so as you move items in the Panel or Workspace, they will automatically adjust to the grid when you finish the move. To see the grid outline, select "Show Grid," and set the Width and Height values of the grid size in pixels. Set the Min (minimum display grid size) to make the display different from the snap grid. For example if you set the snap grid size to 2x2 but the Min. to 8, the snap grid will be 2x2 as set, but the display grid will be 8x8, minimum allowed for display.

Default Table Files - These are the three table files used by ArtWonk. This shows where they are, and gives you the options to change their locations.  See Patch Options for additional information on the table files.

Option Buttons:

Reset Defaults - Removes custom settings by deleting the ArtWonk.ini file. Note that ArtWonk does not store its settings in the Registry; instead they are stored in the .awi files in the Settings folder. 

Restart ArtWonk - Some of the option changes don't go into effect until ArtWonk is restarted.  This button will exit and restart right away.

Clear Snapshots - Erases all Snapshot settings, leaving them all set to the current widget values as the default.

Save Window Size - Saves the current window size as the default.

Reset Displays - Sets all graphics displays to 320x240 and locates them in the upper left of the ArtWonk frame.  Labels the screens with 1-4 in their upper left corners.  Turns Canvas on (visible) and turns the the screens all off. (ArtWonk only.)

Update Mac/Func Doc (normally not visible) - Updates the user created help and label strings in Macro and Function Modules. Normally this is handled automatically, but USB drive versions may need this done manually if the path changes, such as when  changing computers. Only needed when button is visible. Update is processed in the background upon program exit.

Option Checkboxes:

Use Custom Browser for Help - ArtWonk Help uses a browser instead of a compiled help or pdf file.  This is to allow users to extend it, especially user created Macros and Functions.  So the help engine is the one Microsoft builds in as part of IE.  If you prefer to use your own browser choice, check this option and Help will appear in your default browser.

Use Fast Clocks
- Determines whether ArtWonk uses fast response clock timers. Windows Vista and later computers will get better performance with this option checked. Slower computers and earlier Windows versions may have stability issues with it checked.

Run High Priority - Check to run ArtWonk at a higher priority than most (but not all) other tasks. Helps maintain smooth real time MIDI messaging at the expense of some stability. Usually OK on faster and/or multiprocessor computers. Not recommended for slower (< 1 GHz) processors).

Beep on Process Exit - Depending on the memory allocated, files opened, and Macro or Function additions or updates, ArtWonk can be quite slow to completely shut down. This is not normally noticeable because when you exit it immediately shuts down its module processing and then does its clean up as a hidden background task. Select this option if you want to hear a beep when the cleanup process is done and the program fully exits.

Areo Drag Icon - Only visible when running in Vista and later. Some Vista and later desktop graphics are unacceptably slow displaying the drag and drop animation when Areo graphics is turned on. Check this option to use a simple arrow icon for drag and drop when making module connections. This option is on by default when running in Vista and later.

Automatic Backups - When saving a patch file and there had been changes to it , the previous version that is about to be overwritten is first copied to the backup folder (..\Patches\MySaved\Backup\).  Enabled by default, uncheck to disable backups.

Patch Options - Authoring options can be set here or with the System Module property button, and are saved with the .awp patch file. Loading a patch file will update these parameters. All are off by default except the first.

Play Button Resets - Resets the Patch (sends Reset flag to all modules) when the Play Button is clicked. On by default.

Hide Snapshots - Hides shapshots from the panel menu making snapshot access available only via the System Module

Set Workspace and Panel to Current Colors - Overrides the default colors to enable Save with custom Panel and Workspace color selections.

Maximize Panel Window on Load - Sets Program Start up with Panel maximized. (Workspace is not displayed in the window)

Random Numbers repeat after Reset - Check for repeating RNG sequence numbers starting at Reset. Uncheck for non-repeating numbers. When unchecked the RNG seed is set by the system clock timer, so while it is a pseudo random sequence it does not repeat. When checked, the RNG is restarted with the same seed on every Reset.  Each uncheck/check creates a different starting seed.

Password Protect Modules in Patch File - When checked, the Panel of the Patch file remains visible but the Workspace becomes hidden and Workspace modules are protected from unauthorized modification.

Use Names Subfolder - Check to select a sub folder of the Names folder for Program and Bank names, uncheck to return to using the bank and program name files in the main Names folder. See the readme.txt file in the Names folder for details on setting up custom names.

Install Packages - Opens the interface to Install, Update/Pack, or Uninstall ArtWonk/MusicWonk Packages.


Help Menu

Online Manual - opens this help document.

Macros -

Functions -

Patch Info - This button is visible only if patch help is available. When showing, there is a help file for the patch, select to view.  Patch help files are .htm files with the same name as the patch.  You can make your own patch help files by creating an .htm file with an htm editor (this document was prepared with the excellent and free BlueGriffon editor), or you can use Word and save the file as an htm document.

  Packages - Menu of help documents for any Packages that are installed. Not visible if no Packages have been installed.

About - About this software info box that includes version and license information.

Visit Web Site - Opens to the Algorithmic Arts web site.

Register - Contains information and link button to purchase a license key, and the dialog to register your key when it is emailed to you.


ArtWonk is Copyright 2003-2014 by John Dunn and Algorithmic Arts. All Rights Reserved.