Main Menu

File   Layout   Options   Help

File Menu

New - erases the BankStep workspace. If there were changes made to the current BankStep workspace (the File Changed LED will be on) you will first be asked if you want to Save. New discards the current setup and reloads the last (default) Layout. Note that this may be different from the QuickSave file you may have been working with because it rebuilds from the Layout file, not the last saved patch file. If you want to revert to the last saved patch file, use Revert. New is duplicated in the File Control Buttons in the Toolbar. (Not available in Player.)

Revert - reloads the unnamed QuickSave file. This will revert BankStep to the latest of: 1. the setup that was automatically loaded when you first started up BankSave; 2. the last BankSave file you Opened; 3. the last QuickSave.

Open... - invokes a standard Windows dialog box to open a previously created BankStep file. Duplicated in the File Control Buttons in the Toolbar.

BankStep system files have the extension ".bsp" - they save the state of BankStep, including Snapshots and all parameter values and connections of all the Snapshots.

There are two auxiliary file types that may be used with BankStep, which are automatically loaded when the .bsp file is loaded, if any are in the same directory and have the same filename as the .bsp file. These are:

BioSequencer table files (.bst)
Pitch Bend Tuning table files (.pbt)

Normally, BankStep uses the default versions of these files, which is always loaded automatically when BankStep is run; if you load an .bsp file that also includes one of the auxiliary files, and subsequently load another .bsp file that does not include one, then the default auxiliary file is loaded again.

QuickSave - saves the current setup in an unnamed fast load format; it is the same file that is automatically saved upon exit and loaded when you first start up BankStep.

Save - Saves the currently opened BankStep (.bsp) file. If no .bsp file has been opened, acts as Save As... (below). Duplicated in the File Control Buttons in the Toolbar. (Not available in Player.)

SaveAs... - Invokes the standard Windows File Save dialog to save the BankStep workspace. (Not available in Player.)

Bio Sequence... - Loads a DNA or protein sequence file for use with the Bio Sequencer, as created by the Bio Editor (available separately from Algorithmic Arts).  Does not alter the default Bio Sequence file.

Tuning Table... - Loads a Tuning Table .pbt data file and makes it the current source of tunings for the MIDI module, when using Pitch Bend Tuning. Does not alter the default tuning table file.

Exit - Exits BankStep.If there were changes made to the current BankStep workspace (the File Changed LED will be on) you will first be asked if you want to Save. Whether or not you choose to save your work in a named file, the QuickSave unnamed file is always automatically saved. If you do not want changes saved to the QuickSave file, use Revert just prior to exiting. Exit is the same as the Windows Close "X" icon in the upper right of the title bar.

Recently Opened File List - The four most recently opened files are listed here. Select a file name to open it.

Layout Menu

Layouts are the arrangements of modules that define your BankStep workspace. You are free to create Layouts from any combination of any number of modules; once the layout is created it becomes the template for the workspace you have defined.

Layouts have no connections or settings, they are only the unconnected modules. Therefore there is no need for Layouts in the BankStep Player, and the Layout menu does not appear in the Player.

Load Layout - Load a previously constructed Layout file. The layout file is loaded into BankStep, then it is converted into an empty BankStep patch, which becomes the current patch, as if you had loaded it from a patch file. After loading a Layout, you are free to start making settings and connections, and you can create Snapshots or save the patch just as with any other BankStep patch.

Edit Layout - Opens the Layout utility, where you can edit the current module layout scheme or to create your own from scratch. When you create a Layout, you choose which modules to work with and how they are positioned. After a Layout is created, the modules become "fixed" much as if they were bolted into an equipment rack. While you do have the option of changing a Layout at any time, modifying a layout resets any saved module connection patches - just as you would have to remove patchcords from a hardware rack before rearranging or adding to the modules in a rack.

Help Menu

BankStep Help... - opens this help document with your default browser.

Visit Web Site... - links to the Algorithmic Arts web site: http://algoart.com

About... - standard Windows About box that includes version and license information.

Remove Registration - Removes the registration from your computer. After registration is removed, SoftStep will revert to the free 30 day trial. Only visible when Registered.

BankStep is Copyright © 2001-2004 by John Dunn and Algorithmic Arts. All Rights Reserved.